Задать вопрос
21 февраля, 16:13

Определить, сколько раз в тексте встречается заданное слово. Написать программу, Паскаль

+1
Ответы (1)
  1. 21 февраля, 19:34
    0
    Var

    s, sl, sc: string;

    i, k: integer;

    begin

    write ('Введите текст ') ;

    readln (s) ;

    write ('Введите слово ') ;

    readln (sl) ;

    s:=' '+s+' ';

    sl:=' '+sl+' ';

    for i : = 1 to length (s) - length (sl) + 1 do

    begin

    sc : = copy (s, i, length (sl)) ;

    if sc = sl then inc (k) ;

    end;

    if k = 0 then writeln ('Не встречается')

    else writeln ('Встречается ', k, ' раз') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить, сколько раз в тексте встречается заданное слово. Написать программу, Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Паскаль Дана строка. Если в этом числе буква f встречается только один раз, выведите её индекс. Если она встречается два и более раз, выведите индекс её первого и последнего появления. Если буква f в данной строке не встречается, ничего не выводите.
Ответы (1)
Ввести текст. Определить сколько раз встречается заданное слово. Паскаль
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)