Задать вопрос
1 марта, 11:35

Ниже записан алгоритм. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 4, а потом 0. var x, a, b, c: integer; begin readln (x) ; a: = 0; b: = 0; while x > 0 do begin c: = x mod 2; if c = 0 then a: = a + 1 else b: = b + 1; x: = x div 6; end; writeln (a) ; writeln (b) ; end.

+3
Ответы (1)
  1. 1 марта, 13:22
    0
    Тем не менее, несмотря на ту безалаберность, с которой вы скинули задачу, я все же захотел ее решить.

    По условию мы видим, что а - 4, б - 0 (в конце задачи)

    Такое может произойти из условия, что на вход поступит четное число, которое сможет поделится на 6 4 раза, ни разу не обернувшись в нечетное, ибо тогда станет б>0, что не есть верно.

    6^4 = 1296, именно это и есть ответ. Ответ: 1296
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ниже записан алгоритм. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 4, а потом 0. var x, a, b, c: ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике