Задать вопрос
13 июня, 20:59

С клавиатуры вводятся числа, пока не будет введено число, делящееся на 5. Подсчитать количество и сумму тех, которые больше 10.

+2
Ответы (1)
  1. 13 июня, 22:14
    0
    Var a, n, s: integer;

    begin

    a : = 1;

    while a mod 5 0 do begin

    readln (a) ;

    if a > 10 then

    begin

    inc (n) ;

    s : = s + a;

    end;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводятся числа, пока не будет введено число, делящееся на 5. Подсчитать количество и сумму тех, которые больше 10. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
С клавиатуры последовательно вводятся однозначные числа до тех пор пока не будет введено двухзначное число. найди сумму квадратов однозначных чисел (написать программу на языке паслкаль)
Ответы (1)
С клавиатуры вводятся положительные числа до тех пор пока не будет введено отрицательное число. Составить программу, выводящую это число на экран.
Ответы (1)
PaskalABC. Вводятся числа от 1 до 9 до тех пор, пока не будет введен 0. Всего будет введено не больше 100 чисел. Посчитать количество единиц в этой последовательности, количество двоек, количество троек и так далее (должно выводиться всегда 9 чисел).
Ответы (1)