Задать вопрос
5 апреля, 01:37

Составить программу на Паскаль

Из массива Р, содержащего 10 элементов, сформировать массив Н по правилу:

Н (к) = I/P (к), (к - чётные), Н (к) = Р (к) + к, (к - нечётные)

В массиве, содержащем 10 элементов, нечётным элементам присвоить значения квадратов их индек сов.

В массиве, содержащем 10 элементов, напечатать индекс последнего из элементов, равных 0.

+5
Ответы (1)
  1. 5 апреля, 02:45
    0
    {Из массива Р, содержащего 10 элементов, сформировать массив Н по правилу: Н (к) = I/P (к), (к - чётные), Н (к) = Р (к) + к, (к - нечётные) В массиве, содержащем 10 элементов, нечётным элементам присвоить значения квадратов их индексов. В массиве, содержащем 10 элементов, напечатать индекс последнего из элементов, равных 0.}var P:array[1 ... 10] of integer; H:array[1 ... 10] of real; i:integer; index1, index2:integer;

    begin

    writeln ('Введите элементы массива P: ') ; for i:=1 to 10 do begin readln (P[i]) ; end; writeln; writeln ('Массив P: ') ; for i:=1 to 10 do begin write (' '+P[i]+' ') ; end;

    writeln; writeln ('Массив H: ') ; for i:=1 to 10 do begin if (i mod 2 = 0) then begin H[i]:=1/P[i]; end; if (i mod 2 0) then begin H[i]:=P[i]+i; end; end; for i:=1 to 10 do begin write (' '+H[i]+' ') ; end; writeln; writeln; writeln ('Нечётным элементам присваиваем значения квадратов их индексов') ; for i:=1 to 10 do begin if (i mod 2 0) then P[i]:=i*i; end; for i:=1 to 10 do begin if (i mod 2 0) then H[i]:=i*i; end; writeln ('Массив P: ') ; for i:=1 to 10 do begin write (' '+P[i]+' ') ; end;

    writeln; writeln ('Массив H: ') ; for i:=1 to 10 do begin write (' '+H[i]+' ') ; end; writeln; writeln; writeln ('Напечатать индекс последнего из элементов, равных 0') ; for i:=1 to 10 do begin if (P[i] = 0) then index1:=i; end; writeln; writeln ('Индекс для массива P: '+index1) ; for i:=1 to 10 do begin if (H[i] = 0) then index2:=i; end; writeln; writeln ('Индекс для массива H: '+index2) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на Паскаль Из массива Р, содержащего 10 элементов, сформировать массив Н по правилу: Н (к) = I/P (к), (к - чётные), Н ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан алгоритм: Начало Присвоить a значение 1 Присвоить b значение 1 Присвоить c значение 0 Пока a меньше чем 1001 Начало цикла Присвоить b значение b * a Присвоить a значение a + 1 Конец цикла Пока b делится на 6 Начало цикла Присвоить c значение c +
Ответы (1)
Сравните. P. S. напишите решение а) 285 (индекс 10) и 11D (индекс 16) б) 111111 (индекс 2) и 1111 (индекс 8) в) 6 С (индекс 16) и 101001 (индекс 2) г) 55 (индекс 16) и 125 (индекс 8)
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С, В которые содержат: массив В - четные элементы из массива А в порядке их следования в массиве А, массив С - отрицательные элементы массива А в
Ответы (1)