Задать вопрос
25 декабря, 10:12

С + + Напишите программу, которая вводит два вещественных числа (x и y) и вычисляет значение x^y.

+1
Ответы (1)
  1. 25 декабря, 11:23
    0
    function Power (x, y:real) : real;

    { (C) Puporev }

    begin if x=0 then Power:=0

    else

    if x>0 then

    Power:=exp (ln (x) * y)

    else

    Power:=-exp (ln (abs (x)) * y) ;

    end;

    var x, y:real;

    begin

    readln (x, y) ;

    writeln (power (x, y)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С + + Напишите программу, которая вводит два вещественных числа (x и y) и вычисляет значение x^y. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
Программа в Паскале. Напишите программу, которая вводит два вещественных числа, x и y, и вычисляет значение x y. Входные данные Входная строка содержит два вещественных числа, разделённых пробелом.
Ответы (1)
В питоне Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b).
Ответы (1)
3. Напишите и выполните программу на компьютере a. Программа вводит одно число, и вычисляет его квадрат, вычитая из него удвоенное значение введенного числа. b. Программа вводит два числа, выводит сумму квадратов этих чисел минус их произведение. c.
Ответы (1)
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)