Задать вопрос
21 июля, 08:42

В компьютер вводятся 10 любых целых чисел. Нужно подсчитать и один раз напечатать, сколько среди них положительных?

+3
Ответы (1)
  1. 21 июля, 09:47
    0
    Var A, i, k:integer;

    Begin

    Write ('Введите 10 целых чисел: ') ;

    k:=0;

    For i: = 1 to 10 do

    Begin

    Read (A) ;

    if A>0 then k:=k+1

    End;

    Write ('Количество положительных: ', k) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В компьютер вводятся 10 любых целых чисел. Нужно подсчитать и один раз напечатать, сколько среди них положительных? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Составить массив из 10 целых чисел, вывести его на экран и подсчитать количество элементов массива, значения которых не превышают трех 2) Составить массив из 10 целых чисел и вывести его на экран, подсчитать сумму отрицательных и положительных
Ответы (1)
13. Ввести a и b (
Ответы (1)
1. Вводятся 4 числа целого типа : a b c d. определить наибольшее среди них. 2. последовательно вводятся N целых чисел. найти сумму всех отрицательных среди них.
Ответы (1)
Помогите составить программу с оператором while вводятся 5 чисел. определить, сколько среди них положительных (включая 0) и сколько отрицательных. (числа вводятся в одну переменную в цикле).
Ответы (1)
С клавиатуры вводятся 3 числа, подсчитать сколько среди них четных положительных чисел. PS: использовать функцию деления по модулю: a mod b - выдает остаток при делении числа а на число b 15 mod 2=1 15 mod 3=0
Ответы (1)