Задать вопрос
23 июня, 18:43

Напишите функцию которая вычисляет сумму чисел от a до b (pascal ABC)

+3
Ответы (2)
  1. 23 июня, 20:38
    0
    Function isch (a, b: integer) : integer;

    var i, sum: integer;

    begin

    sum:=0;

    for i:=a to b do sum:=sum+i;

    isch:=sum;

    end;
  2. 23 июня, 22:38
    0
    Function SumAB (a, b:integer) : integer;

    begin

    SumAB: = (a+b) * (b-a+1) div 2

    end;

    var

    a, b:integer;

    begin / / тестирование

    Read (a, b) ;

    Writeln ('Сумма от ', a,' до ', b,' равна ', SumAB (a, b))

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите функцию которая вычисляет сумму чисел от a до b (pascal ABC) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)
1. Написать функцию, которая вычисляет минимум из четырёх чисел. 2. Написать функцию, которая вычисляет минимум из двух чисел. В чём ошибка? 1.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Напишите программу в синтаксисе Free Pascal или Turbo Pascal, которая вычисляет выражение, состоящее из чисел и знаков (допускаются только знаки "+" или "-", количество чисел и знаков не ограничено).
Ответы (1)