Задать вопрос
26 сентября, 00:52

Вычислите сумму пяти элементов массива

+4
Ответы (1)
  1. 26 сентября, 01:26
    0
    Первый вариант программы:

    Const

    N = 5;

    Var

    A:array[1 ... N] of integer;

    i:integer;

    S:real;

    Begin

    Randomize;

    S:=0;

    Write ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (21) - 10;

    Write (' ', A[i]) ;

    S:=S+A[i];

    End;

    WriteLn;

    WriteLn ('Сумма его элементов: ', S) ;

    End.

    Пример:

    Исходный массив: - 6 - 9 8 7 1

    Сумма его элементов: 1

    Второй вариант программы:

    Const

    N = 13;

    Var

    A:array[1 ... N] of integer;

    i, S, B:integer;

    Begin

    Randomize;

    S:=0;

    Write ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (21) - 10;

    Write (' ', A[i]) ;

    End;

    WriteLn;

    Write ('Введите номера пяти элементов: ') ;

    For i: = 1 to 5 do

    Begin

    Read (B) ;

    S:=S+A[B];

    End;

    WriteLn ('Их сумма равна: ', S) ;

    End.

    Пример:

    Исходный массив: 0 - 9 6 4 - 7 - 1 9 - 7 - 2 - 4 - 6 4 - 1

    Введите номера пяти элементов: 3 4 7 12 1

    Их сумма равна: 23
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислите сумму пяти элементов массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм P: = 0; For k: = 1 to n do If X[k]
Ответы (1)