Задать вопрос
29 августа, 15:33

Очень нужна помощь с Паскалем!

Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке.

Входные данные

Входная строка содержит три целых числа, разделённых пробелами.

Выходные данные

Программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные.

+2
Ответы (1)
  1. 29 августа, 17:13
    0
    Var

    a, b, c, k:integer;

    Begin

    k:=1;

    Read (a, b, c) ;

    if a=b then k:=k+1;

    if b=c then k:=k+1;

    if c=a then k:=k+1;

    if k=1 then k:=0

    else

    if k=4 then k:=3;

    Write (k)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Очень нужна помощь с Паскалем! Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке. Входные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке. Входные данные Входная строка содержит три целых числа, разделённых пробелами.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Программа в C++ Напишите программу, которая вводит натуральное число N и выводит первые N чётных натуральных чисел. Входные данные Входная строка содержит единственное число - требуемое количество чисел N.
Ответы (1)
Напишите программу в Python 3.3 Напишите программу, которая вводит два целых числа, a и b (a < b), и выводит через пробел 5 случайных целых чисел на отрезке [ a, b ]. Входные данные Входная строка содержит два целых числа a и b, разделённых пробелом.
Ответы (1)