Задать вопрос
29 января, 09:54

Найти все натуральные числа, не превышающие заданного числа N, которые делятся без остатка на каждую из своих цифр

+2
Ответы (1)
  1. 29 января, 11:13
    0
    Var

    N, A, d, k:integer;

    Begin

    Write ('N = ') ; ReadLn (N) ;

    For N: = 1 to N do

    Begin

    A:=N;

    k:=0;

    d:=0;

    While A>0 do

    Begin

    k:=k+1;

    if A mod 10 0 then

    if N mod (A mod 10) = 0 then d:=d+1;

    A:=A div 10;

    End;

    if k = d then WriteLn (N)

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все натуральные числа, не превышающие заданного числа N, которые делятся без остатка на каждую из своих цифр ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Найдите все натуральные числа, не превышающие заданного числа N, которые делятся без остатка на каждую из своих цифр. В ответе укажите результат для N=2017.
Ответы (1)
Из ряда натуральных чисел от 1 до 2000 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Из ряда натуральных чисел от 1 до 1500 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Программа на с++ Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a, b ], делящиеся на каждую из своих цифр.
Ответы (1)
Написать программу в Паскале Найти все натуральные числа, не превосходящие заданного n, которые делятся на каждую из своих цифр.
Ответы (1)