Задать вопрос
3 декабря, 04:03

Найти сумму элементов массива, начиная с первого положительного. паскаль

+5
Ответы (1)
  1. 3 декабря, 06:24
    0
    Const

    K = 13;

    Var

    A:array[1 ... K] of integer;

    i, S:integer;

    Begin

    Write ('Исходный массив: ') ;

    For i: = 1 to K do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ') ;

    End;

    S:=0;

    i:=0;

    Repeat

    i:=i+1;

    if A[i]>0 then

    Repeat

    S:=S+A[i];

    i:=i+1

    Until i>K;

    Until i>=K;

    WriteLn;

    WriteLn ('S = ', S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму элементов массива, начиная с первого положительного. паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)