Задать вопрос
28 июня, 05:10

Массив из 5 элементов заполняется целыми числами. Составьте программу, которая вычисляет количество пар элементов, у которых один элемент - нечетный, а модуль второго меньше 5. Парой элементов считаются два рядом стоящие элемента.

+4
Ответы (1)
  1. 28 июня, 06:12
    0
    Const

    N = 5;

    Var

    A:array[1 ... N] of integer;

    i, k:integer;

    Begin

    Write ('Исходный массив: ') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ') ;

    End;

    WriteLn;

    k:=0;

    For i: = 1 to N-1 do

    if ((A[i] mod 2 0) and (abs (A[i+1]) <5))

    or ((A[i+1] mod 2 0) and (abs (A[i]) <5)) then k:=k+1;

    WriteLn (k)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Массив из 5 элементов заполняется целыми числами. Составьте программу, которая вычисляет количество пар элементов, у которых один элемент - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Массив из 10 элементов заполняется целыми числами. Составьте программу, которая вычисляет среднее арифметическое элементов, заканчивающихся на цифру 7
Ответы (1)
Дан массив А из N целочисленных элементов. 1) Заполнить массив А целыми числами в интервале[1,100] и вывести на экран. Найти максимальный четный элемент и вывести его на экран.
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)