Задать вопрос
10 мая, 13:34

Прошу помогите решить на Паскале полную программу!

Массив из 15 элементов заполнен случайными числами из диапазона (-20; 20). Найти максимальный элемент и его номер, вывести на экран элементы массива с нечетными номерами

+3
Ответы (1)
  1. 10 мая, 14:21
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    max, imax, i:integer;

    begin

    Randomize;

    for i:=1 to n do begin

    a[i]:=random (39) - 19;

    write (a[i],' ') ;

    end;

    writeln;

    max:=a[1]; imax:=1;

    for i:=2 to n do

    if a[i]>max then begin max:=a[i]; imax:=i; end;

    writeln ('max = ', max,' imax = ', imax) ;

    writeln ('Элементы массива с нечетными номерами:') ;

    for i:=1 to n do

    if i mod 2 = 1 then write (a[i],' ') ;

    writeln;

    end.

    Пример:

    -5 18 - 16 - 7 19 - 15 2 8 - 15 - 6

    max = 19 imax = 5

    Элементы массива с нечетными номерами:

    -5 - 16 19 2 - 15
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Прошу помогите решить на Паскале полную программу! Массив из 15 элементов заполнен случайными числами из диапазона (-20; 20). Найти ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив из 25 элементов заполнить случайными числами из диапазона [-100 ... 100] и вывести на экран. Найдите элемент массива с максимальной суммой цифр. 2. Массив из 20 элементов заполнить случайными числами из диапазона [1 ...
Ответы (1)
В pascal. 1) Заполните массив случайными числами из интервала [-50; 50), вывести на экран, посчитать сумму отрицательных элементов. 2) Ввести одномерный массив, вывести его на экран, найти максимальный элемент и его порядковый номер.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)