Задать вопрос
28 апреля, 20:16

Помогите написать программу по информатике (на паскале) на перевод из десятичной системы счисления в двоичную.

+2
Ответы (1)
  1. 28 апреля, 23:18
    0
    Program todec;

    uses crt;

    function detob (x:integer) : string;

    var s:string;

    begin

    s:='';

    while x>0 do

    begin

    s:=chr (ord ('0') + x mod 2) + s;

    x:=x div 2;

    end;

    detob:=s;

    end;

    var a: integer;

    begin

    clrscr;

    writeln ('Введите число:') ;

    readln (a) ;

    writeln ('Полученное число:', detob (a)) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу по информатике (на паскале) на перевод из десятичной системы счисления в двоичную. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1.11010101,00011 переведите число из двоичной в десятичную систему счисления 2.10111101,110111 переведите число из двоичной в восьмиричную систему счисления 3.101100010100,1011 переведите число из двоичной в шестнадцатиричную систему счисления 4.
Ответы (1)
5. Системы счисления. a. Переведите данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления: 114,22510 b. Переведите данные числа в десятичную систему счисления: 100111100,11012 1234,58 2B3, F416 c.
Ответы (1)
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)
7. Под основанием системы счисления понимают: a) количество используемых знаков в алфавите системы счисления; b) наибольшую цифру в алфавите системы счисления; c) название системы счисления;
Ответы (1)
1. Перевести число 11011100 из двоичной в десятичную, восьмеричную и шестнадцатеричную системы счисления 2. Перевести число 471 из восьмеричной в десятичную, двоичную и шестнадцатеричную системы счисления 3.
Ответы (1)