Задать вопрос
5 июня, 06:53

Паскаль. Найти сумму тех элементов двумерного массива, которые больше 1

+2
Ответы (1)
  1. 5 июня, 09:36
    0
    Program n1;

    var a: array[1 ... 10,1 ... 10] of integer;

    i, sum, j: integer;

    begin

    randomize;

    sum:=0;

    writeln ('исходный массив:') ;

    for i:=1 to 10 do

    begin

    for j:=1 to 10 do

    begin

    a[i, j]:=random (10) ;

    write (a[i, j],' ') ;

    if a[i, j]>1 then sum:=sum+a[i, j];

    end;

    writeln;

    end;

    write ('сум. эл >1: ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Найти сумму тех элементов двумерного массива, которые больше 1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Паскаль, составьте программу для двумерного массива: Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)