Задать вопрос
31 августа, 12:02

Напишите программу, которая в последовательности целых чисел определяет 1. количество четных отрицательных чисел

2. среднее арифметическое нечётных чисел

Программа получает на вход целые числа, количество введёных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность.

+2
Ответы (1)
  1. 31 августа, 13:13
    0
    Var a, k1, k2, s:integer;

    begin

    writeln ('Вводите целые числа. Конец ввода - 0') ;

    k1:=0;

    k2:=0;

    s:=0;

    readln (a) ;

    while a0 do

    begin

    if (a mod 2 = 0) and (a<0) then k1:=k1+1;

    if a mod 2 0 then begin k2:=k2+1; s:=s+a; end;

    readln (a) ;

    end;

    writeln ('количество четных отрицательных чисел = ', k1) ;

    if k2>0

    then writeln ('среднее арифметическое нечётных чисел = ', s/k2)

    else writeln ('в последовательности нет нечётных чисел') ;

    end.

    Пример:

    Вводите целые числа. Конец ввода - 0

    18

    -45

    10

    -62

    70

    0

    количество четных отрицательных чисел = 1

    среднее арифметическое нечётных чисел = - 45
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая в последовательности целых чисел определяет 1. количество четных отрицательных чисел 2. среднее арифметическое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3. Программа получает на вход целые числа.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет количество нечетных чисел, кратных 3.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3. Программа получает на выход целые числа.
Ответы (1)