Задать вопрос
10 мая, 12:19

Нужно составить программу, которая на входе должна получать последовательность цифр, после чего программа показывает цифру, порядковый номер которой ввел пользователь.

+4
Ответы (1)
  1. 10 мая, 16:03
    0
    Var

    A:array[1 ... 32767] of byte;

    n:integer;

    Begin

    Write ('Введите количество цифр: ') ; ReadLn (n) ;

    Write ('Введите сами числа: ') ;

    For n: = 1 to n do

    Read (A[n]) ;

    Write ('Введите номер искомой цифры: ') ; ReadLn (n) ;

    Write ('Искомая цифра: ', A[n])

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно составить программу, которая на входе должна получать последовательность цифр, после чего программа показывает цифру, порядковый ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Исполнитель "Умник" получает на входе число, обрабатывает его, и на выходе выдает другое число. Например: на входе 100 = на выходе 25; на входе 48 = на выходе 3; на входе 232 = на выходе 29; на входе 448 = на выходе 7.
Ответы (1)
Напишите программу на паскале А. выясните какие числа ввел пользователь: положительное или отрицательное? Б. выясните какие числа ввел пользователь: четное или нечетное?
Ответы (1)
Программа должна выдавать ошибку если пользователь вводит ноль во втором числе, т. к на 0 делить нельзя и программа отправляет пользователя на повторный ввод, если пользователь умудряется допустить ошибку 3 раза подряд, то программа закрывается.
Ответы (1)
Какое событие наступит после того, как: А) ученик встретит учителя Б) пользователь выберет команду меню В) пользователь выберет объект правой кнопкой мыши Г) пользователь включит компьютер Д) пользователь перетянет левый нижний угол окна
Ответы (1)
Пользователь вводит числа - получается последовательность. Если пользователь ввел 0, то программа прекращает свое действие, сразу выдает результат. Т. е. 0 - конец последовательности.
Ответы (1)