Задать вопрос
10 июля, 22:20

С клавиатуры вводится строка.

Подсчитать и вывести среднее арифметическое цифр в строке.

Pascal ABC

+2
Ответы (1)
  1. 11 июля, 00:32
    0
    Var

    Stroka:string;

    S:real;

    i, k:integer;

    Begin

    Write ('Введите строку: ') ; ReadLn (Stroka) ;

    k:=0;

    S:=0;

    For i: = 1 to Length (Stroka) do

    Begin

    Case Stroka[i] of

    '1':S:=S+1;

    '2':S:=S+2;

    '3':S:=S+3;

    '4':S:=S+4;

    '5':S:=S+5;

    '6':S:=S+6;

    '7':S:=S+7;

    '8':S:=S+8;

    '9':S:=S+9;

    End;

    Case Stroka[i] of

    '0' ... '9':k:=k+1;

    End;

    End;

    WriteLn ('Сумма цифр: ', S) ;

    WriteLn ('Количество цифр: ', k) ;

    WriteLn ('Среднее арифметическое цифр: ', S/k) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится строка. Подсчитать и вывести среднее арифметическое цифр в строке. Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
С клавиатуры вводится строка. Подсчитать и вывести сумму чисел в строке. Pascal ABC
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)