Задать вопрос
4 мая, 22:45

Вводить с клавиатуры числа и посчитать количество четных чисел до нуля.

Создать программу используя Until и Repeat

+3
Ответы (1)
  1. 4 мая, 23:34
    0
    Var A, k:integer;

    Begin

    k:=-1;

    Repeat

    Read (A) ;

    if A mod 2 = 0 then k:=k+1;

    Until A=0;

    WriteLn ('k = ', k)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводить с клавиатуры числа и посчитать количество четных чисел до нуля. Создать программу используя Until и Repeat ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Какие операторы используются для организации циклов? a) while условие until; b) repeat until условие; c) while условие do; d) repeat do условие.
Ответы (1)
Как определить сколько раз будет выполняться тело цикла? 1) s:=0; i:=0 repeat i:=i-1; s:=s+1/i until i2; s=a+1/i;
Ответы (1)
Составить программу на языке pascal. используя цикл repeat ... until. Определить минимальное число из введенной с клавиатуры последовательности положительных чисел, ввод заканчивается отрицательным числом.
Ответы (1)
Напишите программу, которая для последовательности целых чисел определяет количество четных чисел. Программа получает на вход количество чисел в последоввтельности, а затем сами числа. Количество чисел не привышает 1000.
Ответы (1)
Определить значение переменной у после выполнения следующих фрагментов программы: a) Var у : real; i : integer; у : = 1; i : = 5; while i> 2 do i: = i - 1; y:=y + 1 * i; b) Var у : real; i : integer; у : = 1; i : = 2; repeat i: = 2 * i;
Ответы (1)