Задать вопрос
9 марта, 19:43

В одномерном массиве размером N определить среднее значение элементов. Найти индекс элемента массива наиболее близкого к среднему значению. (паскаль)

+1
Ответы (1)
  1. 9 марта, 23:05
    0
    Const

    K = 13;

    Var

    A:array[1 ... K] of integer;

    i, n:integer;

    Sr, d:real;

    Begin

    For i: = 1 to K do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ') ;

    Sr:=Sr+A[i];

    End;

    WriteLn;

    Sr:=Sr/K;

    n:=1;

    d:=abs (Sr-A[n]) ;

    For i: = 2 to K do

    Begin

    if abs (A[i]-Sr)
    Begin

    n:=i;

    d:=abs (Sr-A[n]) ;

    End;

    End;

    WriteLn ('Sr = ', Sr) ;

    WriteLn ('Номер ближайшего к среднему арифметическому: ', n) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одномерном массиве размером N определить среднее значение элементов. Найти индекс элемента массива наиболее близкого к среднему значению. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Сравните. P. S. напишите решение а) 285 (индекс 10) и 11D (индекс 16) б) 111111 (индекс 2) и 1111 (индекс 8) в) 6 С (индекс 16) и 101001 (индекс 2) г) 55 (индекс 16) и 125 (индекс 8)
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)