Задать вопрос
16 декабря, 12:04

3. Заполнить массив случайными целыми числами из отрезка [-10; 10]. Элементам с четными номерами присвоить отрицательные значения, элементам с нечетными номерами - положительные. Вывести полученный массив на экран.

+4
Ответы (1)
  1. 16 декабря, 14:01
    0
    Program n1;

    const n=15;

    var a: array [1 ... n] of integer;

    i, rnd: integer;

    begin

    randomize;

    for i:=1 to n do

    begin

    rnd:=random (21) - 10;

    if (i mod 2=0) and (rnd<0) then a[i]:=rnd;

    if (i mod 20) and (rnd>0) then a[i]:=rnd;

    end;

    for i:=1 to n do write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «3. Заполнить массив случайными целыми числами из отрезка [-10; 10]. Элементам с четными номерами присвоить отрицательные значения, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Дан алгоритм: Начало Присвоить a значение 1 Присвоить b значение 1 Присвоить c значение 0 Пока a меньше чем 1001 Начало цикла Присвоить b значение b * a Присвоить a значение a + 1 Конец цикла Пока b делится на 6 Начало цикла Присвоить c значение c +
Ответы (1)
1. Заполнить массив а [1 ... 14] случайными целыми числами в диапазоне от 1 до 18 и вывести на экран элементы массива с нечетными значениями, меньшими 10. 2. Заполнить массив а [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)