Задать вопрос
13 апреля, 21:50

Напишите программу на языке программирования Pascal. Дано натуральное число n, целые числа а₁, а₂, ..., . Вычислить сумму чисел а₁, а₂, ..., , кратных 3.

+1
Ответы (1)
  1. 14 апреля, 00:15
    0
    Var n, i, k, s : integer;

    Begin

    s:=0;

    Write ('N? ') ; Readln (n) ;

    Writeln ('Вводите a1 a2 ... aN') ;

    For i:=1 to n do

    Begin

    Readln (k) ;

    If k mod 3 = 0 then s:=s+k;

    end;

    Writeln ('Сумма кратных трём: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на языке программирования Pascal. Дано натуральное число n, целые числа а₁, а₂, ..., . Вычислить сумму чисел а₁, а₂, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)