Задать вопрос
18 февраля, 15:28

Составьте программу, по которой вводится произвольное слово. Выбрать число повторов. Вывести число на экран лесенкой (Со сдвигом вправо). Без использования вложенного цикла.

+4
Ответы (1)
  1. 18 февраля, 17:29
    0
    1)

    var s:string; i:integer;

    begin

    write ('Слово: ') ;

    readln (s) ;

    for i:=1 to length (s) do

    writeln (' ':i, s[i]) ;

    end.

    Пример:

    Слово: лесенка

    л

    е

    с

    е

    н

    к

    а

    2)

    var s:string; n, i:integer;

    begin

    write ('Слово: ') ;

    readln (s) ;

    write ('n = ') ;

    readln (n) ;

    for i:=0 to n-1 do

    writeln ('':i*length (s), s) ;

    end.

    Пример:

    Слово: лесенка

    n = 4

    лесенка

    лесенка

    лесенка

    лесенка
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, по которой вводится произвольное слово. Выбрать число повторов. Вывести число на экран лесенкой (Со сдвигом вправо). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Pascal. Тема: Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа. 2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа
Ответы (2)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)