Задать вопрос
13 июля, 00:52

Есть алгоритм 1. Прибавить 1 2. Прибавить 2 3. Умножить на 3 Сколько существует программ получение числа 13 из числа 1, включающих в себя числа 4 и 9

+5
Ответы (1)
  1. 13 июля, 04:34
    0
    На коленке посчитал:

    Ответ: 160

    Const Finish = 13;

    Var N : integer;

    Procedure Go (a : Byte; a4, a9 : boolean; s : String) ;

    Begin

    If (a=Finish) and a4 and a9 then

    Begin

    Inc (N) ;

    Writeln (s) ;

    end

    else

    If a
    Begin

    a4:=a4 or (a=4) ;

    a9:=a9 or (a=9) ;

    Go (a+1, a4, a9, s+'+1') ;

    Go (a+2, a4, a9, s+'+2') ;

    Go (a*3, a4, a9, s+'*3') ;

    end;

    end;

    Begin

    N:=0;

    Go (1, false, false,'1') ;

    Writeln ('Всего вариантов: ', N) ;

    end.

    Результат:

    1+1+1+1+1+1+1+1+1+1+1+1+1

    1+1+1+1+1+1+1+1+1+1+1+2

    1+1+1+1+1+1+1+1+1+1+2+1

    1+1+1+1+1+1+1+1+1+2+1+1

    1+1+1+1+1+1+1+1+1+2+2

    1+1+1+1+1+1+1+2+1+1+1+1

    1+1+1+1+1+1+1+2+1+1+2

    1+1+1+1+1+1+1+2+1+2+1

    1+1+1+1+1+1+1+2+2+1+1

    1+1+1+1+1+1+1+2+2+2

    1+1+1+1+1+1+2+1+1+1+1+1

    1+1+1+1+1+1+2+1+1+1+2

    1+1+1+1+1+1+2+1+1+2+1

    1+1+1+1+1+1+2+1+2+1+1

    1+1+1+1+1+1+2+1+2+2

    1+1+1+1+1+2+1+1+1+1+1+1

    1+1+1+1+1+2+1+1+1+1+2

    1+1+1+1+1+2+1+1+1+2+1

    1+1+1+1+1+2+1+1+2+1+1

    1+1+1+1+1+2+1+1+2+2

    1+1+1+1+1+2+2+1+1+1+1

    1+1+1+1+1+2+2+1+1+2

    1+1+1+1+1+2+2+1+2+1

    1+1+1+1+1+2+2+2+1+1

    1+1+1+1+1+2+2+2+2

    1+1+1+1+2+1+1+1+1+1+1+1

    1+1+1+1+2+1+1+1+1+1+2

    1+1+1+1+2+1+1+1+1+2+1

    1+1+1+1+2+1+1+1+2+1+1

    1+1+1+1+2+1+1+1+2+2

    1+1+1+1+2+1+2+1+1+1+1

    1+1+1+1+2+1+2+1+1+2

    1+1+1+1+2+1+2+1+2+1

    1+1+1+1+2+1+2+2+1+1

    1+1+1+1+2+1+2+2+2

    1+1+1+1+2+2+1+1+1+1+1

    1+1+1+1+2+2+1+1+1+2

    1+1+1+1+2+2+1+1+2+1

    1+1+1+1+2+2+1+2+1+1

    1+1+1+1+2+2+1+2+2

    1+1+2+1+1+1+1+1+1+1+1+1

    1+1+2+1+1+1+1+1+1+1+2

    1+1+2+1+1+1+1+1+1+2+1

    1+1+2+1+1+1+1+1+2+1+1

    1+1+2+1+1+1+1+1+2+2

    1+1+2+1+1+1+2+1+1+1+1

    1+1+2+1+1+1+2+1+1+2

    1+1+2+1+1+1+2+1+2+1

    1+1+2+1+1+1+2+2+1+1

    1+1+2+1+1+1+2+2+2

    1+1+2+1+1+2+1+1+1+1+1

    1+1+2+1+1+2+1+1+1+2

    1+1+2+1+1+2+1+1+2+1

    1+1+2+1+1+2+1+2+1+1

    1+1+2+1+1+2+1+2+2

    1+1+2+1+2+1+1+1+1+1+1

    1+1+2+1+2+1+1+1+1+2

    1+1+2+1+2+1+1+1+2+1

    1+1+2+1+2+1+1+2+1+1

    1+1+2+1+2+1+1+2+2

    1+1+2+1+2+2+1+1+1+1

    1+1+2+1+2+2+1+1+2

    1+1+2+1+2+2+1+2+1

    1+1+2+1+2+2+2+1+1

    1+1+2+1+2+2+2+2

    1+1+2+2+1+1+1+1+1+1+1

    1+1+2+2+1+1+1+1+1+2

    1+1+2+2+1+1+1+1+2+1

    1+1+2+2+1+1+1+2+1+1

    1+1+2+2+1+1+1+2+2

    1+1+2+2+1+2+1+1+1+1

    1+1+2+2+1+2+1+1+2

    1+1+2+2+1+2+1+2+1

    1+1+2+2+1+2+2+1+1

    1+1+2+2+1+2+2+2

    1+1+2+2+2+1+1+1+1+1

    1+1+2+2+2+1+1+1+2

    1+1+2+2+2+1+1+2+1

    1+1+2+2+2+1+2+1+1

    1+1+2+2+2+1+2+2

    1+2+1+1+1+1+1+1+1+1+1+1

    1+2+1+1+1+1+1+1+1+1+2

    1+2+1+1+1+1+1+1+1+2+1

    1+2+1+1+1+1+1+1+2+1+1

    1+2+1+1+1+1+1+1+2+2

    1+2+1+1+1+1+2+1+1+1+1

    1+2+1+1+1+1+2+1+1+2

    1+2+1+1+1+1+2+1+2+1

    1+2+1+1+1+1+2+2+1+1

    1+2+1+1+1+1+2+2+2

    1+2+1+1+1+2+1+1+1+1+1

    1+2+1+1+1+2+1+1+1+2

    1+2+1+1+1+2+1+1+2+1

    1+2+1+1+1+2+1+2+1+1

    1+2+1+1+1+2+1+2+2

    1+2+1+1+2+1+1+1+1+1+1

    1+2+1+1+2+1+1+1+1+2

    1+2+1+1+2+1+1+1+2+1

    1+2+1+1+2+1+1+2+1+1

    1+2+1+1+2+1+1+2+2

    1+2+1+1+2+2+1+1+1+1

    1+2+1+1+2+2+1+1+2

    1+2+1+1+2+2+1+2+1

    1+2+1+1+2+2+2+1+1

    1+2+1+1+2+2+2+2

    1+2+1+2+1+1+1+1+1+1+1

    1+2+1+2+1+1+1+1+1+2

    1+2+1+2+1+1+1+1+2+1

    1+2+1+2+1+1+1+2+1+1

    1+2+1+2+1+1+1+2+2

    1+2+1+2+1+2+1+1+1+1

    1+2+1+2+1+2+1+1+2

    1+2+1+2+1+2+1+2+1

    1+2+1+2+1+2+2+1+1

    1+2+1+2+1+2+2+2

    1+2+1+2+2+1+1+1+1+1

    1+2+1+2+2+1+1+1+2

    1+2+1+2+2+1+1+2+1

    1+2+1+2+2+1+2+1+1

    1+2+1+2+2+1+2+2

    1*3+1+1+1+1+1+1+1+1+1+1

    1*3+1+1+1+1+1+1+1+1+2

    1*3+1+1+1+1+1+1+1+2+1

    1*3+1+1+1+1+1+1+2+1+1

    1*3+1+1+1+1+1+1+2+2

    1*3+1+1+1+1+2+1+1+1+1

    1*3+1+1+1+1+2+1+1+2

    1*3+1+1+1+1+2+1+2+1

    1*3+1+1+1+1+2+2+1+1

    1*3+1+1+1+1+2+2+2

    1*3+1+1+1+2+1+1+1+1+1

    1*3+1+1+1+2+1+1+1+2

    1*3+1+1+1+2+1+1+2+1

    1*3+1+1+1+2+1+2+1+1

    1*3+1+1+1+2+1+2+2

    1*3+1+1+2+1+1+1+1+1+1

    1*3+1+1+2+1+1+1+1+2

    1*3+1+1+2+1+1+1+2+1

    1*3+1+1+2+1+1+2+1+1

    1*3+1+1+2+1+1+2+2

    1*3+1+1+2+2+1+1+1+1

    1*3+1+1+2+2+1+1+2

    1*3+1+1+2+2+1+2+1

    1*3+1+1+2+2+2+1+1

    1*3+1+1+2+2+2+2

    1*3+1+2+1+1+1+1+1+1+1

    1*3+1+2+1+1+1+1+1+2

    1*3+1+2+1+1+1+1+2+1

    1*3+1+2+1+1+1+2+1+1

    1*3+1+2+1+1+1+2+2

    1*3+1+2+1+2+1+1+1+1

    1*3+1+2+1+2+1+1+2

    1*3+1+2+1+2+1+2+1

    1*3+1+2+1+2+2+1+1

    1*3+1+2+1+2+2+2

    1*3+1+2+2+1+1+1+1+1

    1*3+1+2+2+1+1+1+2

    1*3+1+2+2+1+1+2+1

    1*3+1+2+2+1+2+1+1

    1*3+1+2+2+1+2+2

    Всего вариантов: 160
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Есть алгоритм 1. Прибавить 1 2. Прибавить 2 3. Умножить на 3 Сколько существует программ получение числа 13 из числа 1, включающих в себя ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Что такое программное обеспечение? * совокупность программ, которые используются в ходе разработки, корректировки или развития других прикладных или системных программ * совокупность программ и документации, обеспечивающих функционирование
Ответы (1)
Постоянное запоминающее устройство служит для: а) хранение программ начальной загрузки компьютера и тестирования его узлов б) хранения программы пользователя во время работы в) хранения постоянно используемых программ г) записи особо ценных программ
Ответы (1)
Постоянное запоминающие устройство служит для хранения ... А: Особо ценных прикладных программ Б: Особо ценных документов В: Постоянно используемых программ Г: Программ начальной загрузки компьютера и тестирования его узлов
Ответы (1)
Сетевые операционные системы - это :1) комплекс программ для одновременной работы группы пользователей 2) комплекс программ, переносимых в сети с одного компьютера на другой 3) комплекс программ, обеспечивающих обработку, передачу и хранение данных
Ответы (2)
Соедини стрелками назначение программ и названия вида программ системные программы для решения задач пользователя прикладные программы для разработки новых пр программ инструментальные программыы обеспечивают работу компьютера и взаимодействие
Ответы (1)