Задать вопрос
13 сентября, 21:35

Вычислите n-й член последовательности, заданной формулами: a2n = an + an-1, a2n+1 = an - an-1, a0 = a1 = 1. Входные данные Вводится одно натуральное число n (1≤n≤1000). Выходные данные Вывести одно число an.

+3
Ответы (1)
  1. 13 сентября, 23:42
    0
    Var i, n, k: integer;

    a: array[0 ... 1000] of integer;

    begin

    write ('n = ') ; readln (n) ;

    a[0]:=1; a[1]:=1;

    i:=2;

    repeat

    k:=i div 2;

    if (i mod 2) = 0 then a[i]:=a[k]+a[k-1]

    else a[i]:=a[k]-a[k-1];

    i:=i+1;

    until i>n;

    writeln ('a (n) = ', a[n]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислите n-й член последовательности, заданной формулами: a2n = an + an-1, a2n+1 = an - an-1, a0 = a1 = 1. Входные данные Вводится одно ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
В кафе мороженое продают по три шарика и по пять шариков. Можно ли купить ровно k шариков мороженого? Входные данные Вводится число k (целое, положительное) Выходные данные Программа должна вывести слово YES, если при таких условиях можно набрать
Ответы (1)