Задать вопрос
4 октября, 05:22

Написать программу по задаче: Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма двух старших и сумма двух младших разрядов. 2. Полученные два числа записываются друг за другом в порядке невозрастания (без разделителей).

+3
Ответы (1)
  1. 4 октября, 07:29
    0
    Var

    A, B:integer;

    Begin

    ReadLn (A) ;

    B: = (A div 1000) + ((A div 100) mod 10) ;

    A: = ((A div 10) mod 10) + (A mod 10) ;

    if A>=B then Write (B, A)

    else if B>=A then Write (B, A)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу по задаче: Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автомат получает на вход два трехзначных числа. По этим числам строится новое число по следующим правилам. Вычисляются три числа - сумма старших разрядов заданных трехзначных чисел, сумма средних разрядов этих чисел, сумма младших разрядов.
Ответы (1)
Автомат получает на вход четырёхзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма первой и второй цифр и сумма третьей и четвёртой цифр заданного числа. 2.
Ответы (1)
Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма первой, третьей и пятой цифр и сумма второй и четвёртой цифр заданного числа. 2.
Ответы (1)
1. Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма первых трёх цифр и сумма последних трёх цифр. 2.
Ответы (2)
Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам: 1) вычисляются два числа - сумма "кратчайших" цифр четырехзначного числа, а также сумма "средних" цифр заданного
Ответы (1)