Задать вопрос
5 июня, 14:23

Составьте программу которая в массиве A из 20 произвольных чисел находит произведение минимального элемента и среднего арифметического элементов данного массива

+4
Ответы (1)
  1. 5 июня, 18:02
    0
    Лови)

    const

    k = 20;

    var

    A: array [1 ... k] of real;

    i: integer;

    min, average: real;

    begin

    writeln ('Enter x:') ;

    for i : = 1 to k do

    begin

    A[i] : = random (k) ;

    writeln ('A[', i, '] = ', A[i]) ;

    end;

    min : = A[i];

    average : = 0;

    for i : = 1 to k do

    begin

    average : = average + A[i] / k;

    if min > A[i] then

    min : = A[i];

    end;

    writeln (min * average) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу которая в массиве A из 20 произвольных чисел находит произведение минимального элемента и среднего арифметического ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)