Задать вопрос
29 ноября, 16:15

Задача и в отделе Y есть 15 сотрудников, а в G 20. В течение месяца каждый сотрудник отработал некоторое количество дней, которое задача как случайная величина знаниями у_n = random (30), n = 1,2 ..., 15 g_k = random (30), k = 1,2, ..., 20. Денна оплата труда d в условных единицах. Налоговая ставка 20% ... Используя процедуры и функции, создавая массива y, g, вывести значение их элементов на экран и выполнить задачу поиска данных для каждого виддилу. 1) Сколько человеко-дня было отработано в каждом отделе?

+5
Ответы (1)
  1. 29 ноября, 18:59
    0
    Program z3; Var y: array [1 ... 15] of real; g: array [1 ... 20] of real; i, d, a, b: integer; sum, sum_2: real; Begin writeln ('Введите оплату труда за день') ; read (d) ; a: = 0; b: = 0; for i : = 1 to 15 do begin y[i] : = random (30) ; if (y[i] < 10) then a: = a + 1; y[i] : = y[i] * d * 0.8; end; for i:=1 to 20 do g[i] : = random (30) ; if (g[i] < 10) then b: = b + 1; g[i] : = g[i] * d * 0.8; for i:=1 to 15 do begin writeln ('Сотрудник y_', i,' - ', y[i]) ; sum: = sum + y[i]; end; writeln; writeln ('Сумма отдела y - ', sum) ; writeln; for i:=1 to 20 do begin writeln ('Сотрудник g_', i,' - ', g[i]) ; sum_2: = sum_2 + g[i]; end; writeln; writeln ('Сумма отдела g - ', sum_2) ; writeln; writeln ('В отделе y ', a, ' сотрудников работало меньше 10 дней') ; writeln; writeln ('В отделе g ', b, ' сотрудников работало меньше 10 дней') ; End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача и в отделе Y есть 15 сотрудников, а в G 20. В течение месяца каждый сотрудник отработал некоторое количество дней, которое задача ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)