Задать вопрос
25 октября, 20:38

Pascal

Написать программу, переводящую десятичное число в двоичную систему

+3
Ответы (1)
  1. 25 октября, 21:54
    0
    Var

    A:longint;

    B:string;

    Begin

    Write ('A = ') ;

    ReadLn (A) ;

    A:=Abs (A) ;

    While A > 0 do

    Begin

    if A mod 2 = 0 then B:='0'+B

    else B:='1'+B;

    A:=A div 2

    End;

    WriteLn (B)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal Написать программу, переводящую десятичное число в двоичную систему ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
N2 Перевести десятичное число 25 в двоичную систему счисления. N3 Перевести десятичную дробь 0,75 в двоичную систему счисления N4 Перевести десятичное число 12,25 в двоичную систему счисления
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Составьте программу на паскале переводящую дробное не десятичное число с основанием р (2-9) в десятичную систему счисления
Ответы (1)
1. Переведите известным вам способом число 12 в двоичную систему счисления. 2. Переведите известным вам способом число 0,375. в двоичную систему счисления 3. Переведите известным вам способом число 12,375 в двоичную систему счисления.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)