Задать вопрос
7 ноября, 08:00

Используя язык программирования pascal, написать программу, которая вычисляет следующую сумму S = (2*4) / (1+2) - (6*8) / (2+3) + (10*12) / (3+4) - ... - (54*56) / (14+15) и выводит ее результат.

Писать нужно через цикл, желательно, с пояснением.

+3
Ответы (1)
  1. 7 ноября, 10:21
    0
    Var i, z:integer; a, s:real;

    begin

    s:=0; z:=-1;

    for i:=1 to 56 div 4 do

    begin

    z:=-z;

    a:=z * (i*4-2) * (i*4) / (i+i+1) ;

    / / для наглядности:

    writeln (z,' ', i*4-2,' ', i*4,' ', i,' ', i+1) ;

    s:=s+a;

    end;

    writeln ('s = ', s) ;

    end.

    Результат:

    1 2 4 1 2

    -1 6 8 2 3

    1 10 12 3 4

    -1 14 16 4 5

    1 18 20 5 6

    -1 22 24 6 7

    1 26 28 7 8

    -1 30 32 8 9

    1 34 36 9 10

    -1 38 40 10 11

    1 42 44 11 12

    -1 46 48 12 13

    1 50 52 13 14

    -1 54 56 14 15

    s = - 54.4163713045239
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Используя язык программирования pascal, написать программу, которая вычисляет следующую сумму S = (2*4) / (1+2) - (6*8) / (2+3) + (10*12) / ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Используя язык программирования задачи 8, написать программу, которая вычисляет произведение сумм всех соседних пар целых чисел из диапазона от 12 до 36 и выводит значения тех сумм, которые меньше 52. 8.
Ответы (1)
Как сделать задачу в turbo pascal которая запрашивает с клавиатуры 2 произвольных числа X и Y. Если разность X и Y больше 0, то вычисляет и выводит на экран сумму всех целых чисел от Y до X, иначе вычесляет и выводит на экран разность всех целых
Ответы (1)