Задать вопрос
20 февраля, 00:31

В магазин привезли X кг картофеля. В первый день продали 1/4 всего картофеля, во второй день - 2/5 остатка. Сколько килограммов картофеля осталось продать? На языке Паскаль надо написать

+4
Ответы (1)
  1. 20 февраля, 01:42
    0
    Var

    x, prod1, prod2, ost:real;

    begin

    Write ('Привезено картофеля, кг: ') ;

    Read (x) ;

    prod1:=x*1/4; { продано в первый день }

    ost:=x-prod1; { остаток от продажи }

    prod2:=ost*2/5; { продано во второй день }

    ost:=x - (prod1+prod2) ;

    Writeln ('Оcталось продать, кг: ', ost)

    end.

    Примеры

    Привезено картофеля, кг: 2540

    Оcталось продать, кг: 1143

    Привезено картофеля, кг: 743

    Оcталось продать, кг: 334.35
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В магазин привезли X кг картофеля. В первый день продали 1/4 всего картофеля, во второй день - 2/5 остатка. Сколько килограммов картофеля ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Задача магазин за три дня продал 250 кг яблок. В первый день продал 3/5 всех яблок, во второй 3/4 остатка, а в третий день продал последние яблоки. Сколько килограммов яблок продали в третий день?
Ответы (2)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)