Задать вопрос
14 июня, 05:22

Задача №309. Голосование

Напишите "функцию голосования"

function Election (x, y, z:boolean) : boolean

Входные данные

Вводится 3 числа - x, y и z (x, y и z равны 0 или 1, 0 соответствует значению false, 1 соответствует значению true).

Выходные данные

Необходимо вывести значение функции от x, y и z.

Примеры

0 0 1

0

+3
Ответы (1)
  1. 14 июня, 08:51
    0
    Program n1;

    var x, y, z: integer;

    function Election (x, y, z: integer) : boolean;

    begin

    if (x=0) and (y=0) then Election:=false

    else

    begin

    Election:=true;

    if (x=0) and (z=0) then Election:=false

    else

    begin

    Election:=true;

    if (y=0) and (z=0) then Election:=false

    else Election:=true;

    end;

    end;

    end;

    begin

    readln (x, y, z) ;

    if Election (x, y, z) = true then

    writeln (1) else writeln (0) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача №309. Голосование Напишите "функцию голосования" function Election (x, y, z:boolean) : boolean Входные данные Вводится 3 числа - x, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выберите логическое выражение, принимающее значение True a) (True and True) and (False or False) b) Not (True and Not False) or False c) (True or False) or Not (True and True) d) Not (True or False) and True
Ответы (1)
Задача №308. Исключающее ИЛИ Напишите функцию function _Xor (x, y:boolean) : boolean (Pascal) Входные данные Вводится 2 числа - x и y (x и y равны 0 или 1, 0 соответствует значению false, 1 соответствует значению true).
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)