Задать вопрос
16 августа, 20:20

Составить программу на языке паскаль которая меняет местами два числа без ввода дополнительной ячейки

+5
Ответы (1)
  1. 16 августа, 23:50
    0
    A:=a+b;

    b:=a-b;

    a:=a-b;

    var a, b: real;

    procedure change (var a, b: real) ;

    begin

    a : = a + b; writeln (a) ;

    b : = a - b; writeln (b) ;

    a : = a - b; writeln (a) ;

    end;

    begin

    writeln ('a, b:') ;

    readln (a, b) ;

    writeln ('a=', a) ;

    writeln ('b=', b) ;

    change (a, b) ;

    writeln ('a=', a) ;

    writeln ('b=', b) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на языке паскаль которая меняет местами два числа без ввода дополнительной ячейки ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В паскале! Написать два алгоритма ввода трех вещественных переменных A, B, C и обмена значений в ячейках памяти A в В, В в С, С в А. Первый алгоритм с применением дополнительной ячейки памяти и второй алгоритм без использования дополнительной ячейки.
Ответы (1)
Для объединения двух и более ячеек в одну используется функция Word, которая называется: A. Объединить ячейки B. Объединить выделенные ячейки C. Объединить все ячейки D. Разбить ячейки
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)