Задать вопрос
15 августа, 11:03

Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале, используя простые формулы.

+2
Ответы (1)
  1. 15 августа, 12:31
    0
    Var a:string[20]; st, b, i:integer;

    begin

    writeln ('Введите двоичное число:') ;

    readln (a) ;

    st:=1; b:=0;

    for i:=length (a) downto 1 do

    begin

    if a[i]='1' then b:=b+st;

    st:=2*st;

    end;

    writeln (b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале, используя простые формулы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Выполните сложение в двоичной системе счисления: 101112 + 1011102 Результат запишите в двоичной системе счисления. 2. Выполните сложение в двоичной системе счисления: 11012 + 110112 Запишите ответ в двоичной системе счисления.
Ответы (1)
А) 1000001110 в двоичной системе счисления+1100110 в двоичной системе счисления б) 10001001 в двоичной системе счисления-1010101 в двоичной системе счисления в) 45 в восьмеричной системе счисления * 71 в восьмеричной системе счисления г) 1AF1 в
Ответы (1)
1.11010101,00011 переведите число из двоичной в десятичную систему счисления 2.10111101,110111 переведите число из двоичной в восьмиричную систему счисления 3.101100010100,1011 переведите число из двоичной в шестнадцатиричную систему счисления 4.
Ответы (1)
1. Переведите число 221 из системы счисления с основанием 3 в десятичную 2. Переведите число 123 из системы счисления с основанием 7 в десятичную 3. Переведите число 323 из системы счисления с основанием 4 в десятичную 4.
Ответы (1)
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)