Задать вопрос
22 мая, 15:17

Для настольной игры используются карточки с номерами от 1 до N. Одна карточка потерялась. Найдите ее, зная номера оставшихся карточек.

Входные данные

Дано число N, далее N-1 номер оставшихся карточек (различные числа от 1 до N).

Выходные данные

Программа должна вывести номер потерянной карточки.

+5
Ответы (1)
  1. 22 мая, 18:59
    0
    Var n, i, k, s1, s2:integer;

    begin

    write ('n=') ; readln (n) ;

    s1:=n; s2:=0;

    for i:=1 to n-1 do

    begin

    write ('k', i,'=') ; readln (k) ;

    s1:=s1+i; s2:=s2+k;

    end;

    writeln ('Потерялась карточка ', s1-s2) ;

    end.

    Пример:

    n=5

    k1=1

    k2=3

    k3=4

    k4=5

    Потерялась карточка 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для настольной игры используются карточки с номерами от 1 до N. Одна карточка потерялась. Найдите ее, зная номера оставшихся карточек. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Решить на Паскале или Питоне, или. хотя бы алгоритм Задача: Для настольной игры используются карточки с номерами от 1 до N. Одна карточка потерялась. Найдите ее, зная номера оставшихся карточек.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)