Задать вопрос
15 октября, 04:58

Паскаль. вычислить сумму трех членов прогрессии 1, 1+1/2, 1+1/3, 1+1/4 ... которые меньше заданного числа В где 1<В<2

+5
Ответы (1)
  1. 15 октября, 05:48
    0
    Прогрессия неправильная, т. к. первый элемент должен быть 1+1/1 = 2

    var b, sum:real; count, n:integer;

    begin

    readln (b) ;

    count:=0;

    n:=1;

    while count3 do begin

    if (1+1/n)
    sum:=sum + (1+1/n) ;

    count:=count+1;

    end;

    n:=n+1;

    end;

    writeln ('suma: ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. вычислить сумму трех членов прогрессии 1, 1+1/2, 1+1/3, 1+1/4 ... которые меньше заданного числа В где 1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Заданы первый член арифметической прогрессии а, разность прогрессии d и количество членов прогрессии k. Вычислить k-1 и к-ые члены арифметической прогрессии и сумму первых n членов Sn.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Найти сумму 10 членов арифметической прогрессии A, A+D, A+2D, ..., где А - первый член прогрессии, D - постоянное слагаемое, разность прогрессии. Паскаль
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)