Задать вопрос
26 июня, 12:41

Вася загадал число от 1 до N. За какое наименьшее количество вопросов (на которые Вася отвечает "да" или "нет") Петя может угадать Васино число?

Входные данные

Вводится одно число N

Выходные данные

Выведите наименьшее количество вопросов, которого гарантированно хватит Пете, чтобы угадать Васино число.

Примеры

входные данные

5

выходные данные

3

+5
Ответы (1)
  1. 26 июня, 15:32
    0
    Var n, k:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    k:=trunc (ln (n-1) / ln (2)) + 1;

    writeln ('k = ', k) ;

    end.

    Пример:

    n = 5

    k = 3
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вася загадал число от 1 до N. За какое наименьшее количество вопросов (на которые Вася отвечает "да" или "нет") Петя может угадать Васино ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
У студента-филолога Васи есть замечательный друг Петя. И Петя никак не может выучить английский язык. Английский текст Петя еще кое-как читает, но пишет с ужасными ошибками, причем чаще всего он вставляет в слова лишние буквы. Вася решил помочь Пете.
Ответы (1)
В англо-русском словарике 80 страниц, на каждой из который по 50 слов. Петя открыл словарь на случайной странице и загадал случайное слово с этой страницы. Сможет ли Витя угадать его за 12 вопросов? Петя отвечает на вопросы только "да" или "нет".
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Вася загадал число от 1 до 233. Петя может выделить из множества чисел от 1 до 233 некоторое подмножество и спросить, принадлежит ли ему загаданное число. Если будет ответ "Да", то Пете нужно отдать Васе 2 рубля, если будет ответ "Нет", то 1 рубль.
Ответы (1)