Задать вопрос
1 июля, 11:14

Помогите составить задачу в программе pascal.

Для приготовления квашеной капусты на 10 кг капусты берут 225 г соли, 350 г моркови, 200 г клюквы, 4 г лаврового листа. Сколько соли, моркови, клюквы и лаврового листа надо взять, если закуплено М кг капусты?

+2
Ответы (2)
  1. 1 июля, 13:54
    0
    Понадобиться 225 одушпе
  2. 1 июля, 14:59
    0
    Лови

    var

    m, a:integer;

    b, col, mor, kl, la:real;

    begin

    write ('Сколько кг капусты = ') ;

    readln (m) ;

    a:=m div 10;

    b:=m mod 10;

    mor:=350*a;

    kl:=200*a;

    col:=225*a;

    la:=4*a;

    b:=b*0.1;

    mor:=mor+350*b;

    kl:=kl+200*b;

    col:=col+225*b;

    la:=la+4*b;

    writeln ('На ', m,'кг капусты надо: Морковки - ', mor,'г. Клюквы - ', kl,'г. Соли - ', col,'г. Лаврового листа - ', la,'г') ;

    end.

    Тут программа только с двузначными числами работает то есть 15 кг 30 кг и так далее.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить задачу в программе pascal. Для приготовления квашеной капусты на 10 кг капусты берут 225 г соли, 350 г моркови, 200 г ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача по информатике: для приготовления квашеной капусты на 10 кг капусты берут 225 грамм соли, 350 грамм моркови, 200 грамм клюквы, 4 грамма лаврового листа. Сколько соли, моркови, клюквы и лаврового листа надо взять, если закуплено М кг капусты?
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Написать программу к задаче на паскале Расчитать какую массу соли и воды надо взять для приготовления раствора массой m грамм с массовой долей соли w%, w=m (соли) / m, m (соли) = w*m, m (воды) = m-m (соли).
Ответы (1)
Почему приведенные ниже алгоритмы для исполнителя арифмометр не могут быть выполнены (какие свойства алгоритма нарушены) А) взять число 4; взять число 5; умножить; вычесть; результат. Б) взять число 6; взять число 3; разделить; результат.
Ответы (1)