Задать вопрос
29 мая, 00:45

Сформировать массив из 10 случайных целых чисел из промежутка от - 5 до 5, вывеси элементы массива в строку черенз пробел, найти сумму всех положительных элементов.

+3
Ответы (1)
  1. 29 мая, 03:10
    0
    Var

    a:array[1 ... 10] of integer;

    i, s:integer;

    begin

    s:=0;

    for i:=1 to 10 do

    begin

    a[i]:=random (10) - 5;

    if a[i]>0 then

    s:=s+a[i];

    write (a[i],' ') ;

    end;

    writeln;

    writeln ('Сумма пол. = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать массив из 10 случайных целых чисел из промежутка от - 5 до 5, вывеси элементы массива в строку черенз пробел, найти сумму всех ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов;
Ответы (1)
Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С, В которые содержат: массив В - четные элементы из массива А в порядке их следования в массиве А, массив С - отрицательные элементы массива А в
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)