Задать вопрос
18 января, 10:59

Сформировать случайным образом массив из 25 целых чисел в промежутке [-10; 10]. Составить программу удвоения чётных значений элементов и вывода массива в строку

+1
Ответы (1)
  1. 18 января, 14:14
    0
    Var a:array[1 ... 30] of integer;

    n, i:integer;

    begin

    randomize;

    for i:=1 to 25 do begin

    a[i]:=random (-10,10) ;

    write (a[i]:4) ;

    end;

    writeln () ;

    for i:=1 to 25 do begin

    if a[i] mod 2=0 then a[i]:=a[i]*2;

    write (a[i]:4) ;

    end;

    end.

    изи бризи
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать случайным образом массив из 25 целых чисел в промежутке [-10; 10]. Составить программу удвоения чётных значений элементов и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)
Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов;
Ответы (1)