Задать вопрос
14 ноября, 17:57

Нужно составить алгоритм.

Задание.

Уменьшить на 0,9 наибольшее из двух вещественных чисел х, у

+1
Ответы (1)
  1. 14 ноября, 19:03
    0
    C#:

    {

    double x = Convert. ToDouble (Console. ReadLine ()) ;

    double y = Convert. ToDouble (Console. ReadLine ()) ;

    if (x > y)

    {

    x = x / 0,9;

    }

    else if (y > x)

    {

    y = y / 0,9;

    }

    else Console. WriteLine ("Числа одинаковые / n") ;

    Console. WriteLine ("x = {0}, y = {1}", x, y) ;

    }

    надеюсь, что устроит

    более-менее понятно, можно разобраться

    на паскале:

    begin

    var x, y: double;

    readln (x) ;

    readln (y) ;

    if x > y then

    x : = x div 0,9;

    else if y > x then

    y : = y div 0,9;

    else writeln ("числа одинаковые") ;

    writeln ("x = ", x, "y = ", y) ;

    на паскале мб чутка неверно написано
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно составить алгоритм. Задание. Уменьшить на 0,9 наибольшее из двух вещественных чисел х, у ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
В питоне Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b).
Ответы (1)
Язык Pascal: Разветвляющийся алгоритм Составить алгоритм решения задачи для определения максимального значения из двух различных вещественных чисел.
Ответы (1)
1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов. 2. Написать прогрумму, которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.
Ответы (1)
Умоляю помогите, мне нужно составить Алгоритм своего имени, зовут меня Нурлан Мне необходимо составить алгоритм каждой буквы: н, у, р, л, а, н Примерно алгоритм выглядит вот так - Поднять перо. Сместиться в точку. Опустить перо. Сместиться на вектор.
Ответы (1)