Задать вопрос
16 мая, 18:16

Помогите прошу.

Составить программу, которая вводит с клавиатуры любое число от 150 до 255, и выводит символ, соответствующий этому коду.

+3
Ответы (1)
  1. 16 мая, 19:31
    0
    Формула для рандома:

    : = Random (b-a+1) + a,

    где:

    a - начальное значение диапазона;

    b - конечное значение диапазона.

    chr - в озвращает символ с определённым номером.

    var

    x: byte;

    begin

    randomize;

    x:=random (255-150+1) + 150;

    writeln ('Число: ', x) ;

    writeln ('Символ: ', chr (x)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите прошу. Составить программу, которая вводит с клавиатуры любое число от 150 до 255, и выводит символ, соответствующий этому коду. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какие из последовательностей могут быть масками? 255.255.255.122 255.255.128.255 255.255.156.0 255.255.255.192 255.255.224.192 255.255.255.128 255.255.128.128 255.255.128.0 255.255.255.102 255.255.248.0
Ответы (1)
Помогите составить программу в Pascal ABC Составить программу, которая определяет: a) символ по его коду, введенному с клавиатуры; b) символ для кода 100; c) код для символа ' ' (пробел).
Ответы (1)
Определите, каким цветам из набора: красный, зеленый, синий, белый, черный, соответствуют следующие десятичные коды в системе RGB. Ответ дайте по каждому пункту подробно. 1) 0,255,0; 2) 255,255,255; 3) 0,0,0; 4) 0,0,255; 5) 255,0,0 Ответ:
Ответы (1)
Определить, каким цветам из набора красный, зелёный, синий, белый, чёрный соответствует следующие десятичные коды в системе RGB: 0,255,0; 255,255,255; 0,0,0; 0,0,255; 255,0,0
Ответы (1)
Какая из перечисленных комбинаций соответствует черному цвету в палитре RGB? А) 255, 255,255 Б) 255, 128, 0 В) 0, 0, 0 Г) 128, 255, 255
Ответы (1)