Задать вопрос
16 ноября, 04:59

Купец привез на рынок рулон сукна длиной N вершков, но для уплаты пошлины ему нужно указать длину сукна в саженях, аршинах, пядях и вершках. Помогите ему - переведите длину сукна, записанного в вершках в сажени, аршины, пяди и вершки.

Программа получает на вход одно натуральное число N, не превосходящее 2109, - длину сукна в вершках.

Программа должна вывести 4 целых неотрицательных числа S, A, P, V - количество саженей, аршин, пядей и вершков, в сумме дающих ровно N вершков, при этом значение A должно быть меньше 3 (т. к. 3 аршина дают одну сажень), значение P должно быть меньше 4 (четыре пяди дают один аршин), значение V должно быть меньше 4 (четыре вершка дают одну пядь).

+3
Ответы (1)
  1. 16 ноября, 07:26
    0
    Var n, s, a, p, v:integer;

    begin

    write ('N = ') ; readln (n) ;

    s:=n div (3*4*4) ;

    a: = (n mod (3*4*4)) div (4*4) ;

    p: = (n mod (4*4)) div 4;

    v:=n mod 4;

    writeln ('s = ', s,' a = ', a,' p = ', p,' v = ', v) ;

    end.

    Пример:

    N = 2061

    s = 42 a = 2 p = 3 v = 1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Купец привез на рынок рулон сукна длиной N вершков, но для уплаты пошлины ему нужно указать длину сукна в саженях, аршинах, пядях и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В старорусской системе мер 1 сажень = 3 аршинам 1 аршин = 4 пядям 1 пядь = 4 вершкам 1 вершок = 1,75 дюймов Дано расстояние S = 68 в вершках. Найти количество полных саженей, аршинов, пядей и вершков.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Перевести расстояние в километрах в вид: версты, сажени, аршины. 1 верста = 1000 саженей 1 сажень = 2,1336 метра 1 аршин = 71,12 см
Ответы (1)
В 17 веке основной мерой в россии была казенная сажень равная 2,16 м, и содержащая 3 аршина (72 см) по 16 вершков. Еще во времена Петра 1 русские меры длины были уравнены с английскими; 1 сажень=7 английским футов=84 дюйма=2,1336 метра.
Ответы (1)
В 17 веке основной мерой в России была казённая сажень равная 2.16 м. и содержащая три аршина (72 см) по 16 вершков. Еще во времена Петра 1 русские меры длинны были уравнены с английскими: 1 сажень=7 английских фунтов=84 дюйма=2.1336 метра.
Ответы (1)