Задать вопрос
5 февраля, 06:37

Помогите написать программу на языке паскаль

1. вывести все числа от 1 до 10 с помощью while;

2. вывести все числа от 1 до 10 с помощью repeat

+2
Ответы (1)
  1. 5 февраля, 10:23
    0
    Var

    a, b:integer;

    begin

    a:=0;

    b:=0;

    //Вывод через while

    while a10 do

    begin

    inc (a) ;

    write (a,' ') ;

    end;

    writeln ('') ;

    //Вывод через repeat

    repeat

    begin

    inc (b) ;

    write (b,' ') ;

    end;

    until b=10;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на языке паскаль 1. вывести все числа от 1 до 10 с помощью while; 2. вывести все числа от 1 до 10 с помощью ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Определить значение переменной у после выполнения следующих фрагментов программы: a) Var у : real; i : integer; у : = 1; i : = 5; while i> 2 do i: = i - 1; y:=y + 1 * i; b) Var у : real; i : integer; у : = 1; i : = 2; repeat i: = 2 * i;
Ответы (1)
1) Какие операторы используются для организации циклов? a) while условие until; b) repeat until условие; c) while условие do; d) repeat do условие.
Ответы (1)