Задать вопрос
17 июля, 11:49

У исполнителя Калькулятор две команды, которым присвоены номера:

1. прибавь 1

2. прибавь 2

3. умножь на 4

Сколько есть программ, которые число 1 преобразуют в число 13? Ответ обоснуйте.

+4
Ответы (1)
  1. 17 июля, 14:05
    0
    Всего вариантов: 298

    Обоснование:

    Var k : Integer;

    Procedure Go (n : Integer; S : String) ;

    Begin

    If n=13 then

    Begin

    Writeln (S) ;

    Inc (k) ;

    end

    else

    If n<13 then

    Begin

    Go (n+1, S+'1') ;

    Go (n+2, S+'2') ;

    Go (n*4, S+'3') ;

    end;

    end;

    Begin

    k:=0;

    Go (1,'') ;

    Writeln ('Всего вариантов: ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «У исполнителя Калькулятор две команды, которым присвоены номера: 1. прибавь 1 2. прибавь 2 3. умножь на 4 Сколько есть программ, которые ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
38) У исполнителя Калькулятор три команды, которым присвоены номера: 1. прибавь 2 2. прибавь 3 3. прибавь 5 Программа для исполнителя - это последовательность команд. Сколько существует программ, которые число 20 преобразуют в число 35?
Ответы (1)
5) У исполнителя Калькулятор три команды, которым присвоены номера: 1. прибавь 1 2. умножь на 2 3. умножь на 3 Сколько есть программ, которые число 1 преобразуют в число 14
Ответы (1)
исполнителя Удвоитель две команды, У исполнителя Удвоитель две команды, которым присвоены номера: 1. умножь на 2.2. прибавь 3 Первая из них увеличивает число на экране 2 раза, вторая - прибавляет к числу 3.
Ответы (1)
У исполнителя Калькулятор две команды, которым присвоены номера: 1) прибавь 2 2) умножь на 3 Выполняя первую из них, Калькулятор прибавляет к числу на экране 2, а выполняя вторую, утраивает его.
Ответы (1)
Исполнитель Май4 преобразует число, записанное на экране. У исполнителя три команды, которым присвоены номера: 1. прибавь 2 2. прибавь 3 3. прибавь 5 Сколько есть программ, которые преобразуют число 20 в 35?
Ответы (1)