Задать вопрос
27 апреля, 16:13

Заполните массив 15 произвольными целыми числами, введя их с клавиатуры и найдите среди них среднее арифметическое.

+4
Ответы (1)
  1. 27 апреля, 17:19
    0
    Program z1; const n = 15; Var a: array [1 ... n] of integer; i:integer; s:real; Begin for i:=1 to n do read (a[i]) ; for i:=1 to n do write (a[i],' ') ; s:=0; for i:=1 to n do s:=s+a[i]; s:=s/n; writeln; writeln ('Сумма элементов = ', s) ; End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполните массив 15 произвольными целыми числами, введя их с клавиатуры и найдите среди них среднее арифметическое. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1 задача: Массив Z (20) заполнить целыми случайными числами в диапазоне от - 20 до 20. Вычислить CP - среднее арифметическое положительных элементов и CN - среднее арифметическое отрицательных элементов массива Z.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)