Задать вопрос
18 октября, 10:44

Вычислить сумму и количество элементов xi>0 массива X. X (30) Xi = (-1) i = (1+i) / корень кубический из i

+5
Ответы (1)
  1. 18 октября, 11:42
    0
    Program sum;

    var

    x: array[1 ... 30] of real;

    i, k: integer;

    s:real;

    begin

    k:=0;

    s:=0;

    for i:=1 to 30 do

    begin

    x[i]: = (1+i) / (Exp (Ln (i) / 3))

    if x[i]>0

    then

    begin

    s:=s+x[i];

    k:=k+1;

    end;

    end;

    writeln ('summa=', s) ;

    writeln ('kolvo elementov=', k) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить сумму и количество элементов xi>0 массива X. X (30) Xi = (-1) i = (1+i) / корень кубический из i ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)