Задать вопрос
5 июня, 18:21

Вводиться n чисел, определить сумму чисел кратных 5 и 10, а так же их количество

+1
Ответы (1)
  1. 5 июня, 21:44
    0
    Const n=10;

    var a: array [1 ... n] of integer; - массив чисел

    var i, j, s: integer;

    begin

    j:=0;

    s:=0;

    for i:=1 to n do a[i]:=random (100) ;

    for i: = 1 to n do

    begin

    if ((a[i] mod 5 = 0) or (a[i] mod 10 = 0)) then

    begin

    s:=s+a[i]; j:=j+1;

    end;

    end;

    writeln ('число чисел, кратных 5 и 10 = ', j) ;

    writeln ('сумма чисел = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводиться n чисел, определить сумму чисел кратных 5 и 10, а так же их количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Вывести на экран числа кратные 16 от 31 до M (M>31) ; 2) Найти сумму 5 натуральных чисел кратных 13; 3) Найти произведение N натуральных чисел кратных 11; 4) Вывести на экран семь первых чисел кратных 7.
Ответы (1)
Написать программу, которая вычисляет сумму первых n целых положительных целых чисел. Количество суммируемых чисел должно вводиться во время работы программы.
Ответы (1)
Вводиться три целых числа, определить сколько кратных 3 В паскале
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)