Задать вопрос
4 августа, 03:14

Пленник, которого держали в охраняемой землянке, делал подземный ход. В первую ночь он прокопал ход длиной 1 м. Каждую следующую ночь из-за потери сил он делал ход на 5% короче. Через сколько дней он сможет сбежать, если до свободы путь 13 м?

Турбо Паскаль

+1
Ответы (1)
  1. 4 августа, 04:25
    0
    Uses crt;

    var

    len, h : real;

    day : integer;

    begin len : = 13;

    h : = 1;

    clrscr;

    while len > 0 do begin

    len : = len - h;

    h : = h - h * 0.05;

    day : = day + 1;

    end;

    write (day) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Пленник, которого держали в охраняемой землянке, делал подземный ход. В первую ночь он прокопал ход длиной 1 м. Каждую следующую ночь из-за ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Что является составляющими языка? а) Синтаксис; б) Семантика; в) Грамматика; г) Морфология. 2. Средой Что есть визуального программирования? а) Турбо Паскаль; б) Турбо в Excel; в) Турбо Дельфи; г) базовые. 3.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Файл input. txt: Мама, короче, мыла, короче, раму. Декан, короче, пропил, короче, бутан. А роза, короче, упала на лапу, короче, Азора. Каждый, короче, охотник желает, короче, знать, где короче сидит фазан В файле input.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Ваня ведёт дневник, где в том числе отмечает, делал он зарядку в этот день или нет. Напишите программу, которая по собранной статистике сообщит, сколько последних дней подряд Ваня делал зарядку, а так же наибольшее число дней подряд когда он делал
Ответы (1)