Задать вопрос
16 декабря, 12:46

Найти сумму всех двузначных чисел кратных 3, не меньших заданного числа N.

Входные данные:

в первой строке одно целое число N, (10 < = N < = 99)

Выходные данные:

одно число, являющееся ответом в соответствии с условием задачи.

Пример 1.

на входе:

90

на выходе:

378

Помогите плииз ((даю 17 б

+1
Ответы (1)
  1. 16 декабря, 14:24
    0
    Var n: integer;

    begin

    read (n) ;

    write ((102 - n) div 3 * ((n + 2) div 3 * 3 + 99) div 2)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму всех двузначных чисел кратных 3, не меньших заданного числа N. Входные данные: в первой строке одно целое число N, (10 < = N < ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Исполнитель "Умник" получает на входе число, обрабатывает его, и на выходе выдает другое число. Например: на входе 100 = на выходе 25; на входе 48 = на выходе 3; на входе 232 = на выходе 29; на входе 448 = на выходе 7.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Найти все двузначные числа, которые кратны заданному числу N. Входные данные: в первой строке одно целое число N, (1 < = N < = 50) Выходные данные: все числа, являющиеся ответом в соответствии с условием задачи. Пример 1.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)